Pro které weby budete potřebovat od ledna 2017 HTTPS, aby je Chrome neoznačil jako nezabezpečené

Nejpoužívanější internetový prohlížeč na světě Google Chrome bude od verze 56, která vyjde v lednu 2017, některé weby označovat jako Nezabezpečené. Toto varování se bude objevovat nalevo od adresního řádku. Ze začátku nebude moc výrazné. V podstatě to bude jen šedivý nápis. Google však v oficiálním vyjádření píše, že v dalších verzích se může změnit nápis na červený a přibude i červený trojúhelník s bílým vykřičníkem. Takovéto varování by už mohlo některé uživatele opravdu vystrašit.

Naštěstí se toto netýká všech webů, pouze těch, kde se přenáší nějaké informace přes formuláře. Zatím je výslovně zmíněno číslo kreditních karet a přihlašovací údaje. Jak však známe Google klidně k tomu může přibýt i něco dalšího, například emailová adresa.

Tato novinka se tak týká v podstatě jen těch, kdo mají na stránce nějaký formulář. Zvláště s heslem. Čísla kreditních karet dnes snad už nikdo přes nezabezpečené připojení neposílá 🙂

Jestliže tedy nechcete, aby Chrome začal strašit uživatele podezřelým varováním, tak budete potřebovat alespoň stránku s formulářem odesílat přes šifrované spojení. Tedy na adresu s HTTPS.

Google nevyžaduje nějaký konkrétní certifikát, bude mu tedy stačit cokoliv, co půjde přes HTTPS. Nabízí se tedy například Let’s Encrypt, který je zdarma a nasazení je velice rychlé a jednoduché. Pokud tedy pomineme úpravy na stránce a různá přesměrování. Je třeba si uvědomit, že internetový prohlížeč varuje uživatele, pokud všechno na stránce nebude stahováno z HTTPS. Hlavně si dejte pozor na obrázky, fonty a různé měření z externích zdrojů.

Pokud na webu formulář pro přihlášení nemáte, tak se vás novinka prozatím nijak nedotkne.

Share Button

Tento článek byl byl přečten 977 krát

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *